Delayed or incomplete response exports and notifications
Incident Report for Department of Better Technology
Resolved
This incident has been resolved.
Posted 15 days ago. Jun 10, 2019 - 09:27 CDT
Identified
We have identified an issue with some response exports and email notifications not completing or being delayed. Engineers are working on a solution.
Posted 18 days ago. Jun 07, 2019 - 16:59 CDT
This incident affected: Screendoor.