AWS S3 Outage impacting file uploads and downloads
Incident Report for Department of Better Technology
Resolved
Amazon's S3 service is back online. Screendoor file uploads and downloads are now functional. We will continue to monitor.
Posted about 1 year ago. Sep 14, 2017 - 14:57 CDT
Monitoring
Our data center is currently experiencing an outage with its file upload/download service (Amazon S3). As a result, Screendoor file uploads and downloads are currently impacted.
Posted about 1 year ago. Sep 14, 2017 - 13:59 CDT