Screendoor emails and notifications
Incident Report for Department of Better Technology
Resolved
This incident has been resolved.
Posted 4 days ago. Dec 06, 2018 - 13:01 CST
Investigating
We are currently investigating an issue sending emails and notifications from Screendoor.
Posted 4 days ago. Dec 06, 2018 - 12:35 CST
This incident affected: Screendoor.