Issues with Screendoor Notification Emails
Incident Report for Department of Better Technology
Resolved
This incident has been resolved.
Posted almost 4 years ago. Jul 14, 2014 - 07:45 HST
Identified
We've identified the problem and are working on pushing out a fix ASAP.
Posted almost 4 years ago. Jul 14, 2014 - 07:29 HST
Investigating
We are currently investigating this issue.
Posted almost 4 years ago. Jul 14, 2014 - 07:23 HST