Intermittent Connectivity Issues
Incident Report for Department of Better Technology
Resolved
This incident has been resolved.
Posted over 3 years ago. Mar 20, 2015 - 05:01 HST
Identified
Our network provider, AWS, is investigating some network connectivity issues. Currently, certain DOBT applications might not be accessible. While this is out of our hands, we're monitoring the situation and will provide timely updates.
Posted over 3 years ago. Mar 20, 2015 - 04:35 HST