Performing scheduled upgrades
Incident Report for Department of Better Technology
Resolved
This incident has been resolved.
Posted about 4 years ago. Jul 13, 2014 - 05:22 HST
Monitoring
We might experience 5-10 minutes of downtime while performing scheduled upgrades to our apps. This maintenance should last no longer than one hour in total.
Posted about 4 years ago. Jul 13, 2014 - 05:04 HST